Pulse Software - Intermittent failures in offer workflows – Incident details

Intermittent failures in offer workflows

Resolved
Partial outage 30 %
Started about 21 hours agoLasted about 21 hours

Affected

Workflow Service

Major outage from 4:24 AM to 5:55 AM, Partial outage from 5:55 AM to 1:05 AM

Updates
  • Resolved
    UTC
    Resolved

    The patch has been deployed and offer workflows are running normally again. We're monitoring closely to confirm the fix holds and that there are no further failures.

  • Identified
    UTC
    Identified

    We've identified the root cause: a recent security update introduced authentication failures affecting offer workflows. A patch to resolve this is scheduled to be deployed tonight. We'll confirm once it's applied and delivery is back to normal.

  • Investigating
    UTC
    Investigating

    We're investigating intermittent failures affecting offer workflows. Some offer-related workflows may fail to run or complete as expected. Other workflows are unaffected. We're looking into the cause and will provide an update