Pulse Software - Service outage affecting all platform features – Incident details

Service outage affecting all platform features

Monitoring
Major outage
Started 1 day ago

Affected

Pulse Web Service

Operational from 1:02 AM to 2:24 AM, Major outage from 2:24 AM to 5:41 AM, Operational from 5:41 AM to 12:00 AM

Forms Service

Operational from 1:02 AM to 2:24 AM, Major outage from 2:24 AM to 5:41 AM, Operational from 5:41 AM to 12:00 AM

Workflow Service

Major outage from 1:02 AM to 5:41 AM, Operational from 5:41 AM to 12:00 AM

Identity Service

Operational from 1:02 AM to 2:24 AM, Major outage from 2:24 AM to 5:41 AM, Operational from 5:41 AM to 12:00 AM

Updates
  • Monitoring
    Monitoring

    A hotfix has been deployed and all services are now restored. Our team is currently validating system health and will be retriggering any failed workflows as soon as possible.

    We will continue to monitor closely and provide a final update once validation is complete. Thank you for your patience throughout this incident.

  • Update
    Update

    We have identified the cause of the ongoing service disruption: an expired TLS certificate is causing connection failures across our services. Our engineering team is working to rotate the certificate and restore service.

  • Identified
    Identified

    Escalation update: the workflow failures reported earlier have expanded — we are now seeing impact across all microservices. We are currently experiencing a major service disruption affecting all of our major services. The issue has been identified as related to SSL certificate validation, and our engineering team is actively working on a fix.

    Customers may experience failures or degraded performance across the platform during this period.

  • Investigating
    Investigating

    We are currently investigating an issue causing workflow failures, first observed this morning. Some workflow executions may fail or be delayed during this period.

    Our engineering team is actively working to identify the root cause. We will post another update within the next 30 minutes, or sooner as new information becomes available.

    We apologize for the disruption and appreciate your patience.