Pulse Software - Delayed morning notifications for some customers (July 29) – Incident details

Delayed morning notifications for some customers (July 29)

Resolved
Partial outage
Started about 1 month agoLasted 3 days

Affected

Email Service

Partial outage from 1:24 AM to 1:25 AM, Operational from 1:25 AM to 1:40 AM

Updates
  • Resolved
    UTC
    Resolved

    This incident is now resolved. Daily scheduled morning notifications have been delivering normally since we addressed the underlying issue, and monitoring has confirmed stable delivery. We apologize for the missed notifications on July 29 and thank you for your patience

  • Monitoring
    UTC
    Monitoring

    Scheduled notifications have been restored and are delivering normally. As a preventive measure, we're migrating the scheduler to Pulse-managed infrastructure for greater reliability, which will reduce the risk of a similar issue in the future. We'll continue monitoring to confirm stability.

  • Identified
    UTC
    Identified

    On July 29th, a resource outage in upstream Microsoft infrastructure disrupted some of our daily scheduled jobs. As a result, some customers may not have received their morning notifications that day. We've identified the cause and are working to restore normal delivery.