Pulse Software - Delayed Notifications (Today, 10:00 AM – 12:00 PM) – Incident details

Delayed Notifications (Today, 10:00 AM – 12:00 PM)

Resolved
Partial outage
Started 14 days agoLasted about 1 hour

Affected

Email Service

Partial outage from 6:17 AM to 7:11 AM

Updates
  • Resolved
    Resolved

    We added additional capacity to our email service, which cleared the backlog instantly. Notifications resumed triggering normally. We are also adding monitoring and autoscaling improvements to prevent this from happening again. No action is required on your part

    We sincerely apologize for any inconvenience this may have caused. If you have any concerns, please reach out to our support team.

  • Identified
    Identified

    Due to heavy load on our email service, notifications queued up and were not delivered as expected during this window

  • Investigating
    Investigating

    We recently identified and investigating an issue that prevented some notifications from being triggered between 10:00 AM and 12:00 PM 29th April 2026